Jump to content

Keep Having to Register at CSC?????


Recommended Posts

Everytime I go to this site, I have to re-register to dispute. Initially for EQ. and then for inquiries.

Anyone else having this issue? It's honestly saying I'm not a registered user everytime I log out and then attempt to return. I then re-register and it's allowing that same username to register, even though I have! THREE TIMES!

Guess I'll be sending them snail mail stuff instead :roll:

Link to comment
Share on other sites

Everytime I go to this site, I have to re-register to dispute. Initially for EQ. and then for inquiries.

Anyone else having this issue? It's honestly saying I'm not a registered user everytime I log out and then attempt to return. I then re-register and it's allowing that same username to register, even though I have! THREE TIMES!

Guess I'll be sending them snail mail stuff instead :roll:

This has happened to me as well!!! I can't even check on the status of my disputed accounts. Makes me wonder if my disputes were ever received.:evil:

Link to comment
Share on other sites

I'll be honest, never even dealt with them. I send all my disputes snail mail to Equifax. If they want to go through CSC, they can forward my communication.

I'm with you on that. Simply go to Equifax's dispute website, enter a zipcode outside of texas and then dispute as normal. I get a letter from EQ once a week stating that my correspondence has been fwd to CSC. It gets things corrected though, just takes a little longer.

Link to comment
Share on other sites

Today I called CSC and spoke with "Becky". I got one deletion instantly: an old OC that had two different balances on one account. The rest she disputed for me over the phone. She told me that none of my disputed info that I've submitted online was on record.

What I've learned: when disputing with CSC forget about doing it online. Use some other means!

Link to comment
Share on other sites

Sent CSC a dispute and accidentally sent EQ one as well on accident (but the same one I sent to CSC...just wasn't paying attention...there went $5.00)

Experian and TU got theirs in the mail today as well. Since the CA is reporting $86 on the account with Verizon as the OC, and Verizon is reporting $169, I sent them the bills I got from both that don't add up, and Verizon should have got their payment yesterday or today. SO, let's hope once the CRA's go to investigate, everything is a mess of paperwork between the two and I get my deletes :D

THEN, I called GAP (GEMB) to report a lost card. Guess what? One 30 day late on that account DISAPPEARED when they reported it lost/stolen. Everything gone. Credit limit gone, balance of $0 gone, all reports were up to 'ok/pays as agreed' NO LATES WHATSOEVER! It raised my score 3 points :D

They only deleted off of one though, but the other two CRA's updated with no lates a while back. Guess it was a good thing I called them to re-issue a new card!!!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.. For more information, please see our Privacy Policy and Terms of Use.