Jump to content

Ok I think I messed up


Guest mediaman24
 Share

Recommended Posts

Guest mediaman24

Ok I was served summons, being sued by a Debt Buyer (July 20, 2019)

I recently just submitted to the Courthouse (California)

  1. My answer w/ Affirmative Defenses (A few days ago)
  2. MTC "Private/Contractual Arbitration and Dismiss or in Alternative, to stay proceedings pending arbitration"

It wasn't until today I noticed I missed a step. I totally forgot to attach a "General Denial - PLD-050" to include with my answer at the courthouse. I was looking at the Proof of Service form also in which I had to include the General Denial for the plaintiff.

  1. Is my filing in error since its all without General Denial Form, even though my answer has affirmative defenses?
  2. Am I screwed, because it is well past 30 days now to submit the Denial?
  3. Can I add a general denial now after the fact to attach to my already filed answer?
  4. Will this all change the process of the Proof of Service form I have to send to the Plaintiff?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.. For more information, please see our Privacy Policy and Terms of Use.